Add Product

Search Results:

Reply
New Member
Posts: 1
Registered: ‎12-04-2018

NS-CSPGASP2 not getting past "SEt" was already previously set up

I have 2 NS-CSPGASP2 that was already happily set up and this 3rd one that is in the house which previously was set up (and was a primary of a pair)
NS-CSPGASP2 #1 <-- technically one with issue
NS-CSPGASP2 #2 <-- was fine and on its own
NS-CSPGASP2 #3 <-- was set up as part of pair with #1 and had been running this way for at least month+

this morning #1 went into NEt mode not being able to connect to my network. not sure why but ended up doing reset.  Now on the SEt screen and asking for gooogle home setup steps.  phone does not see the NS-CSPGASP2 #1 (i have in airplane with wireless, BT, and location on)

 

 

any way to get this one back on my net?

 

 

Highlighted
Posts: 2,152
Topics: 42
Kudos: 363
Blog Posts: 16
Solutions: 133
Registered: ‎08-08-2017

Re: NS-CSPGASP2 not getting past "SEt" was already previously set up

Hey gmmann,

 

Welcome to the forum, and thanks for reaching out to us.  If I'm understanding your post correctly, you had two Insignia Voice Speakers paired together, brought in a third speaker to use, and now two of them are stuck showing SET on the screen; is that right?

 

If you've tried resetting the speaker in question to its factory settings and it cannot connect to your network, I'd suggest ensuring your phone is up to date with the latest firmware and newest version of the Google Home/Assistant apps to see if this will make the device appear on your phone.  For additional troubleshooting steps, I'd recommend contacting Insignia Support at (877) 467-4289 for real-time assistance.

 

I hope this helps.  Happy holidays!

Sam|Retired Social Media Specialist | Best Buy® Corporate
Give Kudos if you like this post or Accept as Solution if it answers your query!