Add Product

Search Results:

Reply
New Member
Mn-Yeti
Posts: 1
Registered: ‎02-05-2009

Samsung HD LCD. Purple dots after powering on

Samsung LCD. HD, Direct TV.. Hit the power button on the Direct TV remote, TV makes the beeping noises like it's turning on.. Nothing. Try again, picture comes up, but has purple dot pixels on the screen. Power off, turn on again and it's fine.. any ideas?
Please use plain text.
New Member
mountaineerfan
Posts: 1
Registered: ‎02-24-2009

Re: Samsung HD LCD. Purple dots after powering on

Mine does the same thing now. I also have a Samsung LCD HD with Directv. Find anything out yet?
Please use plain text.
New Member
mickel1138
Posts: 1
Registered: ‎03-21-2009

Re: Samsung HD LCD. Purple dots after powering on

My TV a L-NT4665F started doing the same thing, after a call with Samsung, first TIER 1 (India), then TIER 2 support (US) they determined that it may be time for out-of-warranty service.

 

This for me started happening more and more,  but just when I first turn the TV on in the morning. And a power-cycle will fix it. I've seen it happen where it want the TV wants to start up, the start "music" and light under the logo appear, but then nothing. Then again it will switch itself on.

 

I guess this started happening with many TV's from the same production bought at BB around june-july 2007.

 

I don't think DirecTV is an issue here, I have noticed it happens usually with HD content.

Please use plain text.
New Member
betty-jean
Posts: 1
Registered: ‎07-26-2009

Re: Samsung HD LCD. Purple dots after powering on

 
Please use plain text.
New Member
xbradx75
Posts: 1
Registered: ‎01-23-2010

Re: Samsung HD LCD. Purple dots after powering on

That's a very common problem, among others, with Samsung's 2007 models. I have a 4665f purchased from BB as well that's started giving it's first signs of the usual bad capacitor problems.

Mine seems to be suffering from soon to fail capacitors on the power board since it wouldn't power on a few days ago until it had been unplugged for awhile. And has also started experiencing random audio dropouts. I was glad when I remembered paying the extra $249 at the time for the service plan, but not so glad when I found my receipt and remembered that it's just the Product Service Plan, and not the standard Product Replacement Plan, so I'm about to get my first experience with my local BB's tv repair crew, or whoever they may contract it out to if there is such a place here in my town.

 

Not sure if I'm allowed to post links to other forums here, but you can find a great owner's thread over at the AVS Forums site that will give more info on your, unfortunately, common problem.

 

Please use plain text.